Trouble With My FX Tarantula...

Trouble With My FX Tarantula...

Postby train222 on Fri Nov 25, 2016 2:36 am

Hello All,

I have had my Tarantula since new. I just had the seals replaced in the rifle. When I recieved the action back, the gun was working as it should. Pull the bolt back, it engages the trigger and readies the rifle to fire. But when I put the action back in the stock, I pulled the bolt back, it does not engage the trigger or ready the rifle to fire. I have talked to a few people about this and they say they think the trigger is hiting something inside the stock. I only shipped the action when I sent it out to have the seals replaced. I did nothing to my stock and my gunsmith told me all he did was replace the seals.

I know that the trigger has two set screws, the one in front to adust the level of the trigger and the one on the trigger shoe to adjust the length of pull…

Do you think the trigger possibly got out of alignment during its travels and this could be causing the problem?

I really do not want to make any adustments to the trigger unless I really have to.

My hands and my eyes aren’t what they use to be and it is difficult to do any work on my guns…

Before I go to the expense of having to ship the entire gun for repair, is there anyone out there that can help me with this problem?

Also, does anyone know of a Airgun Smith or an Individual Person in the Philadelphia, Pa, area that I could take the rifle too, to look at?

Thanking you in advance for any help you can give me on this situation..

Regards,

Stu Gabriel (MrGun)
train222@aol.com
215-969-0726

PS....If you have a chance, please check out my collection on my web site and let me know what you think:
http://www.mrgunsplace.com
train222
 
Posts: 3
Joined: Mon Nov 21, 2016 7:42 pm

Re: Trouble With My FX Tarantula...

Postby Suffolk Rifle on Mon Nov 28, 2016 9:10 pm

Not having had that rifle, can't say if this will be of help, but I know that the Cyclone can have the sear pins move when the action is out of the stock, (all works OK until it gets put back in, apparently) could this have happened?
.177 walnut stocked Cyclone Carbine
.177 mk1 Vermy
.177 walnut stocked L/W Typhoon
.177 synth stocked S/T Typhoon
User avatar
Suffolk Rifle
 
Posts: 210
Joined: Sat Oct 22, 2011 8:37 am
Location: Near Ipswich, UK

Re: Trouble With My FX Tarantula...

Postby Airjason on Wed Aug 09, 2017 6:03 am

I was just working on my Excalibre the past two days. I had to put new stock screws into my gun and found out the gun would not cock. Turns out the trigger has to be in the forward position for the gun to cock. Otherwise the bolt will just freely move back and forth. My trigger guard was touching the trigger so as to prevent it from moving back forward after a shot. I took a file and relieved the problem area on the guard. Gun cocks and shoots now.
Airjason
 
Posts: 5
Joined: Mon Sep 23, 2013 7:13 am

Re: Trouble With My FX Tarantula...

Postby cyclone sniper on Fri Aug 11, 2017 8:01 pm

can you post pictures of the action showing the trigger ?
FX cyclone .22 FAC,
cyclone sniper
 
Posts: 369
Joined: Sat Mar 05, 2011 12:10 pm
Location: co Offaly Ireland EIRE

Re: Trouble With My FX Tarantula...

Postby train222 on Fri Aug 11, 2017 9:21 pm

Thanks for the contact back. I was able to go to a local airgun smith and he fixed the problem. Some how the trigger asembly got out of alighment during the shipping back to me. Hew was able to re-align it and staighten it out so it functions as it should...

Thanks,

Stu Gabriel
train222
 
Posts: 3
Joined: Mon Nov 21, 2016 7:42 pm


Return to FX General

Who is online

Users browsing this forum: No registered users and 2 guests

cron